James Munsch

So after doing some research.

The lateset version of socket.io to use with node 4 is socketio version 1.3.7


Or somewhere there abouts.
So clear the package.json and retry.
See: https://github.com/socketio/socket.io/commit/21ea31a34e0bb83a7aab8f4ff2f6f3c665bb816a